安装git报错Perl5

来源:csdn博客 分类: 文章浏览史 发布时间:2021-01-29 20:01:50 最后更新:2021-01-29 浏览:172
转载声明:
本文为摘录自“csdn博客”,版权归原作者所有。
温馨提示:
为了更好的体验,请点击原文链接进行浏览
摘录时间:
2021-01-29 20:01:50

今天在centos 中安装git 1.9.4 时报错了。

报错内容如下:

usr/bin/perl Makefile.PL PREFIX='/usr/local/git' INSTALL_BASE='' --localedir='/usr/local/git/share/locale'

Can't locate ExtUtils/MakeMaker.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at Makefile.PL line 3.

BEGIN failed--compilation aborted at Makefile.PL line 3.

make[1]: *** [perl.mak] Error 2

make: *** [perl/perl.mak] Error 2

 

网上查了一下解决方法是:

yum install perl-ExtUtils-MakeMaker -y

 

手动安装git

一、安装前准备:

yum install curl curl-devel zlib-devel openssl-devel perl cpio expat-devel gettext-devel -y

 

二、下载git安装包

https://www.kernel.org/pub/software/scm/git/git-1.9.4.tar.gz

 

三、打开Terminal

[root@localhost workspace]# cd ~/Downloads/  enter

[root@localhost workspace]# tar zxf git-1.9.4.tar.gz

[root@localhost workspace]# cd git-1.9.4

执行

[root@localhost workspace]# ./configure --prefix=/usr/local/git/

[root@localhost workspace]# make

[root@localhost workspace]# make install

 

如果make出现上述错误 执行yum install perl-ExtUtils-MakeMaker -y

然后在重新执行./configure ......

 

安装完成后安装目录在/usr/local/git/

 

四、配置环境变量

vim /etc/profile

export  GIT_HOME= /usr/local/git/
export  PATH=$PATH:$GIT_HOME /bin
保存退出vi
[root@localhost workspace]# source /etc/profile
[root@localhost workspace]# git --version
git version 1.9.4
 
 
php技术微信