Vue项目报错:`sass-loader` requires `node-sass` >=4. Please install a compatible version

来源:csdn博客 分类: 文章浏览史 发布时间:2021-07-29 23:01:26 最后更新:2021-07-29 浏览:114
转载声明:
本文为摘录自“csdn博客”,版权归原作者所有。
温馨提示:
为了更好的体验,请点击原文链接进行浏览
摘录时间:
2021-07-29 23:01:26

最近在一个前后端分离的项目中,启动vue前端项目时报以下错误:

Module build failed: Error: `sass-loader` requires `node-sass` >=4. Please install a compatible version.

在网上查看了很多资料,都没有解决vue项目报错问题,后来自己研究了下,发现认为可能是版本的问题,我的电脑是win7的,且node.js是10.x版本。
在这里插入图片描述
因此我将旧的node.js卸载掉,并把缓存系统盘中的npm和npm cache清理掉,安装了node.js12.x版本(最新版已经16.x,系统不支持,只能装12.x),重新输入npm install 和 npm run dev,能够正常显示前端界面。
在这里插入图片描述

php技术微信